Creating A Bootable USB Of Windows/Linux On OS X

on November 12th, 2016 by Hades | No Comments »

With macOS Sierra, El Capitan, Yosemite, or Mavericks, you can use a USB flash drive or other removable media as a startup disk from which to install the Windows/Linux operating system.

These advanced steps are intended primarly for system administrators and others who are familiar with the command line.

  1. Download the ISO you want to use
  2. Open Terminal (in /Applications/Utilities)
  3. Convert .iso to .img using hdiutil:

hdiutil convert -format UDRW -o /path/to/target.img /path/to/source.iso

Rename if OS X gave it a .dmg ending:

mv /path/to/target.img.dmg path/to/target.img

Type diskutil list to get a list of currently connected devices
Insert USB drive you want to use
Run diskutil list again to see what your USB stick gets assigned eg – /dev/disk3
Run diskutil unmountDisk /dev/diskN (where N is the number assigned to your USB stick, in previous example it would be
Run sudo dd if=/path/to/target.img of=/dev/diskN bs=1m (if you get an error, replace bs=1m with bs=1M
Run diskutil eject /dev/diskN and remove your USB stick
The USB stick will now be ready to use

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.